// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\w{3} \d{2} \d{2}:\d{2}:\d{2}) ([a-z]+) ([\w\d\[\]]+): (.*)$").unwrap();
let string = "Jul 28 06:26:52 debian tripwire[29710]: Integrity Check Failed: File could not be opened.
Jun 29 06:54:01 debian kernel: [586133.428279] device eth0 left promiscuous mode
Jul 29 09:29:07 debian kernel: [586139.564278] device eth0 entered promiscuous mode
Dec 14 17:30:45 debian Cacti[14619]: POLLER: WARNING: Cron is out of sync with the Poller Interval!
Jan 29 11:48:59 debian Cacti[14626]: CMDPHP: Host[1] DS[29] WARNING: Result from SNMP not valid.
END of 00:00:00 logging - rotation in progress
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}