use strict;
my $str = 'Jul 28 06:26:52 debian tripwire[29710]: Integrity Check Failed: File could not be opened.
Jun 29 06:54:01 debian kernel: [586133.428279] device eth0 left promiscuous mode
Jul 29 09:29:07 debian kernel: [586139.564278] device eth0 entered promiscuous mode
Dec 14 17:30:45 debian Cacti[14619]: POLLER: WARNING: Cron is out of sync with the Poller Interval!
Jan 29 11:48:59 debian Cacti[14626]: CMDPHP: Host[1] DS[29] WARNING: Result from SNMP not valid.
END of 00:00:00 logging - rotation in progress
';
my $regex = qr/^(\w{3} \d{2} \d{2}:\d{2}:\d{2}) ([a-z]+) ([\w\d\[\]]+): (.*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}