re = /(?<!\* )(@\$[a-z]|@\\?[a-zA-Z])/m
str = '/**
* @param string $someParam comment
* @param $otherParam comment
*/
@function();
@\\function();
@$this->output();
@self::output();
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end